Affichage des résultats 1 à 4 sur 4

Discussion: Plugin Ground Traffic de Marginal

      
   
  1. #1
    Utilisateur enregistré Avatar de jojo64
    Date d'inscription
    février 2015
    Localisation
    France - Pau (Béarn) / Toulouse (Occitanie)
    Messages
    1 673
    Total Downloaded
    0

    Plugin Ground Traffic de Marginal

    Bonjour tout le monde.

    Je pense que vous connaissez tous le plugin Ground Traffic de Marginal, qui permet d'animer des éléments au sol sur une scène.
    Personnellement, j'aime beaucoup ce qu'il propose, ça fait de belles animations, propres et efficaces, bien mieux que ce que propose Laminar par défaut.
    Ce pourquoi j'aimerai particulièrement continuer à l'utiliser....

    Je passerai le problème du plugin, intégré aux scènes et non pas au dossier plugin général, qui fait planter si un trop grand nombre de ce dernier se charge. Je connait le problème, mais une chose à la fois!

    Mais voilà le hic: j'avais paramétré sur XP10 un "groundtraffic.txt" pour ma scène de Tarbes Lourde LFBT. Le temps a passé, XP11 est arrivé, et maintenant avec dernier, je me rend compte que l’anti collision avec l'avion user (par encore essayé avec les multijoueurs) est devenue beaucoup plus sensible, beaucoup trop sensible. Là où sur XP10, le traffic s'arrête entre 5 et 10 mètre autour de l'avion, maintenant il s'arrête dans les 10/20 mètres, surtout vers l'avant de l'avion, même arrêté. Ce qui pose un problème évident puisque plus aucun véhicules n'arrivent à passer sur les voies de circulations, ça bloque tous les traffic, bref c'est la merd..

    Alors du coup voilà ,j'ai contacté Marginal, mais ce dernier semble avoir disparu des écrans, du moins sur XP.
    Je n'arrive à avoir aucun réponse de sa part, que ce soit sur le .org, sur son site, sur GitHub, ou sur son mail perso (que j'ai car j'avais déjà échangé avec lui pour les autogates, à l'époque il m'avait autorisé à les modifier).
    Marginal a laissé sur son Github le code source de son plugin "Ground Traffic" https://github.com/Marginal/GroundTraffic , mais voilà, je n'arrive à rien avec ça...

    Déjà, je n'arrive même pas à le compiler pour Mac à l'état brut, et quand bien même, je ne saurai pas où commencer pour chercher quel modification a apporter au plugin pour diminuer l’anti collision, j'imagine qu'une dataref a changée avec XP11.
    Alors si quelqu'un par ici, s'y connait la dedans et serai en mesure de me filer un petit coup de main, ne serai me dire ce qui est possible ou pas? Je précise que je n'y connait pas grand chose en la matière.

    En vous remerciant.
    Xplane 10.50 / X-plane 11 pour tester mes scènes

    NEW: MacBook Pro 15'' mi-2019 / Intel Core i9 8 cœurs de 9e génération à 2,4 GHz (Turbo 5 GHz) / 32 Go RAM DDR4 à 2 400 MHz / GPU Radeon Pro Vega 20 avec 4 Go de mémoire HBM2 / SSD 4To / OSX Mojave
    OLD: Mac Book Pro 13'' début 2011 / Intel Core I7 2,7 Ghz / 8Gb RAM / Intel Hd Graphics 3000 512 Mo remplacée en 2019 par Intel Hd Graphics 2Go / DD 1To / OSX High Sierra

    Membre/développeur chez XPFR (http://xpfr.org/)

  2. #2
    Utilisateur enregistré Avatar de ailgorbot
    Date d'inscription
    février 2018
    Localisation
    LFPN
    Messages
    1 099
    Total Downloaded
    0
    Sur ce post j'ai l'impression qu'ils ont calé comme toi
    https://forums.x-plane.org/index.php...e-traffic-kit/
    PPL en cours sur LFPN avec l'Aéro-club AIR FRANCE

    Machine : Amstrad CPC464 sous Vulkan

  3. #3
    Utilisateur enregistré Avatar de jojo64
    Date d'inscription
    février 2015
    Localisation
    France - Pau (Béarn) / Toulouse (Occitanie)
    Messages
    1 673
    Total Downloaded
    0
    Oui j'ai vu, personne ne trouve la solution.
    J'ai remarqué dans le code source, un dataref qui pourrait être la cause, mais comme je n'arrive pas à le compiler, impossible de le tester.
    Xplane 10.50 / X-plane 11 pour tester mes scènes

    NEW: MacBook Pro 15'' mi-2019 / Intel Core i9 8 cœurs de 9e génération à 2,4 GHz (Turbo 5 GHz) / 32 Go RAM DDR4 à 2 400 MHz / GPU Radeon Pro Vega 20 avec 4 Go de mémoire HBM2 / SSD 4To / OSX Mojave
    OLD: Mac Book Pro 13'' début 2011 / Intel Core I7 2,7 Ghz / 8Gb RAM / Intel Hd Graphics 3000 512 Mo remplacée en 2019 par Intel Hd Graphics 2Go / DD 1To / OSX High Sierra

    Membre/développeur chez XPFR (http://xpfr.org/)

  4. #4
    Utilisateur enregistré Avatar de jojo64
    Date d'inscription
    février 2015
    Localisation
    France - Pau (Béarn) / Toulouse (Occitanie)
    Messages
    1 673
    Total Downloaded
    0
    Bon j'avance tout doucement.
    Déjà j'ai réussi à compiler pour Mac (puta.. d'OSX Mojave qui n'est plus compatible avec rien...)

    En jetant un coup d’œil au code et en faisant quelques tests, j'ai déjà vu une première base pour l'origine de mon problème:

    En fait dans la partie "plane", le plugin ne charge en premier temps que les acf avions V10, dont il va mesurer les dimensions, la vitesses et le cap pour calculer l'anti-collision.
    Effectivement dans XP11, si je lance un avion au format XP10, le plugin et son anti-collision fonctionnent comme il faut. Pareil si je prend un avion XP11, et que je change juste les première ligne de l'ACF pour le mettre en XP10, ça marche aussi.

    Dans un second temps, il va charger les 'old" avions, c'est à dire tout ceux qui ne sont pas V11, et il va là aussi mesurer les dimensions, la vitesses et le cap pour calculer l'anti-collision, mais je pense dans ce cas là, qu'il rajoute une certaine marge en plus (J'imagine que Marginal s'était rendu compte du manque de précision des anciens ACF, il qu'il a rajouté cette marge au cas où). Le plugin charge donc les avions V11 dans cette catégorie, et rajoute donc cette marge, ce qui explique la sensibilité de l'anti-collision.

    Je cherche a contourner ce problème, pour le moment je fait choux-blanc, mais d'un autre coté ça m'aide à apprendre les subtilités du codage! Si ça se trouve, je finirai par faire des plugisn en plus des scènes!!!
    Xplane 10.50 / X-plane 11 pour tester mes scènes

    NEW: MacBook Pro 15'' mi-2019 / Intel Core i9 8 cœurs de 9e génération à 2,4 GHz (Turbo 5 GHz) / 32 Go RAM DDR4 à 2 400 MHz / GPU Radeon Pro Vega 20 avec 4 Go de mémoire HBM2 / SSD 4To / OSX Mojave
    OLD: Mac Book Pro 13'' début 2011 / Intel Core I7 2,7 Ghz / 8Gb RAM / Intel Hd Graphics 3000 512 Mo remplacée en 2019 par Intel Hd Graphics 2Go / DD 1To / OSX High Sierra

    Membre/développeur chez XPFR (http://xpfr.org/)

Règles de messages

  • Vous ne pouvez pas créer de nouvelles discussions
  • Vous ne pouvez pas envoyer des réponses
  • Vous ne pouvez pas envoyer des pièces jointes
  • Vous ne pouvez pas modifier vos messages
  •